BS EN 61158-4-2:2014
Withdrawn
A Withdrawn Standard is one, which is removed from sale, and its unique number can no longer be used. The Standard can be withdrawn and not replaced, or it can be withdrawn and replaced by a Standard with a different number.
View Superseded by
Industrial communication networks. Fieldbus specifications Data-link layer protocol specification. Type 2 elements
Hardcopy , PDF
English
30-11-2014
31-05-2022
| Committee |
GEL/65/3
|
| DevelopmentNote |
Together with BS EN 61158-4-11, BS EN 61158-4-12, BS EN 61158-4-13, BS EN 61158-4-14, BS EN 61158-4-16, BS EN 61158-4-17, BS EN 61158-4-18, BS EN 61158-4-19, BS EN 61158-4-1, BS EN 61158-4-3, BS EN 61158-4-4, BS EN 61158-4-7 and BS EN 61158-4-8 supersedes BS EN 61158-4. (03/2009)
|
| DocumentType |
Standard
|
| Pages |
342
|
| ProductNote |
THIS STANDARD ALSO REFERS TO ISO/IEC 33091, IETF RFC 951, IETF RFC 1213, IETF RFC 1542, IETF RFC 1643, IETF RFC 2131, IETF RFC 2132, IETF RFC 4541, IETF RFC 5227:2008, ISO/IEC 8802, ISO/IEC 9314-2, ANSI X3.66, ANSI X3.159, ANSI X3J16, IETF RFC 791, IETF RFC 793, IETF RFC 1350, IETF RFC 4702
|
| PublisherName |
British Standards Institution
|
| Status |
Withdrawn
|
| SupersededBy | |
| Supersedes |
1.1 General The data-link layer provides basic time-critical messaging communications between devices in an automation environment. This protocol provides communication opportunities to all participating data-link entities, sequentially and in a cyclic synchronous manner. Foreground scheduled access is available for time-critical activities together with background unscheduled access for less critical activities. Deterministic and synchronized transfers can be provided at cyclic intervals up to 1 ms and device separations of 25 km. This performance is adjustable dynamically and on-line by re-configuring the parameters of the local link whilst normal operation continues. By similar means, DL connections and new devices may be added or removed during normal operation. This protocol provides means to maintain clock synchronization across an extended link with a precision better than 10 µs. This protocol optimizes each access opportunity by concatenating multiple DLSDUs and associated DLPCI into a single DLPDU, thereby improving data transfer efficiency for data-link entities that actively source multiple streams of data. The maximum system size is an unlimited number of links of 99 nodes, each with 255 DLSAP-addresses. Each link has a maximum of 224 related peer and publisher DLCEPs. 1.2 Specifications This standard specifies procedures for the timely transfer of data and control information from one data-link user entity to a peer user entity, and among the data-link entities forming the distributed data-link service provider; the structure of the fieldbus DLPDUs used for the transfer of data and control information by the protocol of this standard, and their representation as physical interface data units. 1.3 Procedures The procedures are defined in terms of the interactions between peer DL-entities (DLEs) through the exchange of fieldbus DLPDUs; the interactions between a DL-service (DLS) provider and a DLS-user in the same system through the exchange of DLS primitives; the interactions between a DLS-provider and a Ph-service provider in the same system through the exchange of Ph-service primitives. 1.4 Applicability These procedures are applicable to instances of communication between systems which support time-critical communications services within the data-link layer of the OSI or fieldbus reference models, and which require the ability to interconnect in an open systems interconnection environment. Profiles provide a simple multi-attribute means of summarizing an implementation’s capabilities, and thus its applicability to various time-critical communications needs. 1.5 Conformance This standard also specifies conformance requirements for systems implementing these procedures. This standard does not contain tests to demonstrate compliance with such requirements.
| Standards | Relationship |
| EN 61158-4-2:2014 | Identical |
| IEC 61158-4-2:2014 | Identical |
| EN 61508-2:2010 | Identical |
| I.S. EN 61158-4-2:2014 | Equivalent |
| UNE-EN 61158-4-2:2014 | Equivalent |
A newer version of this standard is available.